android studioでアプリを開発しているのですが、よ

Writer: admin Type: fidel Date: 2019-02-09 00:00
android studioでアプリを開発しているのですが、よくわからない警告があります。gradleのcompileSdkVersionのところに警告があり、compileSdkVersion(25) should not be lower than targetSdkVersion(26) と出ています。実際、compileSdkVersionは25に、targetSdkVersionは26としています。しかし、アプリの動作に特に問題はありません。この場合、compileSdkVersionの値を変更した方がいいのでしょうか。デバッグは実機で実機(Android 8.0)で行なっています。共感した0###compiler >= targetにするのが普通。新しいSDKの端末に対して、古いSDKでコンパイルした場合、新しいSDKでは廃止された機能がある場合があり、その機能を使った場合、アプリが動作しない。ナイス0
###直しました。

 

TAG